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Welcome

Congratulations on your purchase of the T-Mobile® webConnect 
Rocket™ USB Laptop Stick with T-Mobile webConnect® (also 
referred to as the webConnect Rocket). Your webConnect Rocket  
allows you to experience faster than 3G data transfer speeds 
wherever T-Mobile has HSPA+ network coverage.*
This guide provides you with information to get started. If you need 
additional information, please refer to one of the following options:

n   On the T-Mobile webConnect Manager 
screen, click Help > Help.

n   Visit www.t-mobile.com.

n   Call 1-800-937-8997 for general assistance or call 
877-822-SPOT for assistance with T-Mobile  
HotSpot or Wi-Fi.

* HSPA+ is not available in all markets. Your device will still work wherever service is available 
on T-Mobile’s nationwide 3G network.
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Get Started

Before you begin

You will need the following:
n	 A webConnect Rocket
n	 A T-Mobile webConnect Data Plan 
n	 A Subscriber Identity Module (SIM) card
n	 A computer with the following minimum requirements 

(see below) 

Computer requirements
You will need a computer with the following minimum 
requirements:

T-Mobile webConnect Data Plans
T-Mobile’s webConnect Data Plans allow you to connect to the 
Internet through T-Mobile’s Broadband and HotSpot Networks. 

n   Using webConnect for Broadband HSPA+, 3G, 2G Access 
T-Mobile’s rapidly expanding 3G network provides faster data 
transfer rates than 2G (also known as EDGE/GPRS) and even 
faster data transfer rates than 3G where T-Mobile HSPA+ is 
available. If 3G is not available, the webconnect Rocket will 
automatically try to find T-Mobile’s 2G network. The plans 
also provide global roaming access in many countries where 
T-Mobile coverage is available and roaming agreements are  
in place.
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n	 Using T-Mobile HotSpot Network for Wi-Fi Access 
The webConnect Manager also allows you to control your 
connections to home, work, and public Wi-Fi networks.  
The included T-Mobile HotSpot account provides access to Wi-
Fi in numerous locations worldwide. With your webConnect 	
Data Plan, you have unlimited Wi-Fi access at nearly 10,000 
locations in the T-Mobile HotSpot Network, including Starbucks, 
Barnes & Noble Bookstores, select Hyatt Hotels & Resorts, 
Red Roof Inns, Sofitel and Novotel Hotels, the airline clubs of 
American®, Delta, United®, and US Airways®, Dallas Fort Worth 
International Airport, Los Angeles International Airport, San 
Francisco International Airport, and other airports. You can also 
use your account at thousands of roaming locations worldwide 
(roaming charges may apply). For a complete listing of T-Mobile 
HotSpot Network locations, at the main webConnect Manager 
screen, click the Wi-Fi tab, then click Tools > HotSpot Locator. 
 
International broadband use requires international service 
activation; usage does not apply toward monthly data 
allowance. International rates apply.

NOTE: For data services, you may need to wait up to 24 hours for the service to be activated. By 
activating service, you acknowledge that you have read and agreed to the Terms and Conditions 
of the Service Agreement. 

Installation & Setup

Insert SIM card  
 
Your Subscriber Identity Module (SIM) card identifies you to the 
wireless network. You will not be able to connect to the network 
without your SIM card. 

1.	Remove the SIM card cover.

2.	Insert the SIM card into the  
SIM card slot with the golden  
contacts facing down and  
the notched corner facing out. 

3.	Replace the SIM card slot  
cover.
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T-Mobile Broadband

Connect to T-Mobile Broadband
You do not need to add a profile or change settings to connect to 
T-Mobile Broadband. 

1.	Make sure your SIM card is in your WebConnect Rocket.
2.	Insert your WebConnect Rocket into your laptop.
3.	Open the webConnect Manager.
4. Click the T-Mobile Broadband tab.Your WebConnect Rocket 

will then scan the area for available networks.
5.	Click Connect.

Connect to other networks
To connect to another network, you must first create a profile 
for that network. Consult with your IT administrator if needed for 
applicable settings. To create a profile:

1.	Open the webConnect Manager and click the  
T-Mobile Broadband tab.

2.	Click Tools > Profiles. The Profiles screen opens.
3.	At the Profiles screen, click Add.
4.	Click Broadband and then click Add.

Insert memory card
Your webConnect Rocket supports a microSDHCTM memory card  
(not included with your purchase). 

NOTE: Do not remove your memory card 
while it is in use. Removing the memory 
card while in use may corrupt the data 
stored on your memory card and damage 
the memory card or your WebConnect Rocket.

Slide the memory card into the memory 
card slot with the golden contacts facing 
the back side of your webConnect Rocket.

Install the webConnect Manager
Connect your WebConnect Rocket to the USB port of your computer. 
For Windows®, the webConnect Manager installs automatically.  

For MAC, follow the instructions below:
1.	Insert your WebConnect Rocket into your laptop. A virtual 

webConnect Mgr CD-ROM opens on your desktop.
2.	Double-click the webConnect Mgr CD-ROM.
3.	Open the MacUsersStartHere.html file for instructions on how 

to install the webConnect Manager software on your MAC. 
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Send and receive text messages
When you are connected to broadband, you can receive and send  
short text messages to mobile phones or to another device that 
supports text messaging.

Read text messages
When you receive a new text message, the webConnect Manager 
displays the Envelope    icon with a red star on the main 
Broadband screen.

1.	Open the webConnect Manager and click the  
T-Mobile Broadband tab.

2.	Click the Envelope  icon.
3.	Make sure Inbox is selected.
4.	Double-click the message you want to read.

Write and send text messages
1.	Open the webConnect Manager and click the  

T-Mobile Broadband tab.
2.	Click the MSG     button. 

5.	Select the profile of the network you would like to add or  
select Create Customer Profile if you want to create a profile 
for a network that is not listed.

6.	Click Next.
7.	On the Broadband screen, configure your settings as needed 

and click Next.
8.	On the IP Settings screen, configure your settings as needed 

and click Next. 
9.	On the General screen, configure the remainder of the settings 

for your profile and click Finish. 

Connect to other networks 
Connecting to other broadband networks may incur roaming 
charges.

1.	Open the webConnect Manager and click the  
T-Mobile Broadband tab.

2.	Click Tools > Profiles.
3.	Click the network that you want to connect to.
4.	Click Connect.

Separate charges apply to send/receive domestic/international text messages.
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Check usage data
Your data plan includes a monthly allowance of 3G and 2G data 
usage. A per megabyte overage charge applies if you exceed your 
monthly data allowance. You will receive free text messages from 
T-Mobile if you are approaching or have reached your monthly data 
usage allowance. Wi-Fi usage through T-Mobile HotSpot as well as 
any other open Wi-Fi connection is unlimited and does not count 
against your monthly data allowance.

To track your data usage by going to the webConnect Manager:

1.	Open the webConnect Manager and click the T-Mobile 
Broadband tab.

2.	Click Usage meter.
3.	Select the billing period start date. You can get your billing 

start date by going to http://my.t-mobile.com.

3.	Click New to open the new message screen.
4.	At the To line, type the destination phone number OR click To 

to open the address book to select a contact saved in your 
address book.

5.	Type your message and click Send.

Manage text messages 

n	 Click	 	 or click File > Folders > New Folder 
to create a new folder to store messages.

n	 Click	 	 or click File > Folders > Delete Folder 
to delete a folder (and all the messages it contains).

n	 Click	 	 or click Edit > Move to Folder to 
move the selected message to another folder. 

n	 Click	 	 or click Edit > Copy to Folder to place 
a copy of the selected message in another folder.
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Wi-Fi

You can get Wi-Fi Internet access on the T-Mobile HotSpot Network 
by connecting to T-Mobile Wi-Fi Network. Internet access at 
these T-Mobile HotSpot and partner locations is included in your 
webConnect Data Plan. 

Connect to T-Mobile HotSpot roaming locations
You can use your T-Mobile HotSpot username and password 
at thousands of roaming locations around the world (additional 
charges may apply). To see a list of these locations, click the Wi-Fi 
tab and click Tools > HotSpot Locator. 

1.	Make sure that you are at a T-Mobile HotSpot Network 
location. 

2.	Open the webConnect Manager on your laptop.
3.	Click the Wi-Fi tab to scan for available networks.
4.	Click Connect.  

 
You will be prompted to type your username 
and password to your T-Mobile HotSpot account. Your 
username is your 10-digit phone number and your default 
password is the last four digits of your Social Security number. 

Check software updates
You may receive periodic updates to your webConnect Manager 
software. You can also manually check for updates. 

Check updates manually
1.	Open the webConnect Manager and click the T-Mobile 

Broadband tab.
2.	Click Tools > Settings.
3.	Click the Updates tab.
4.	Click Update Now to check for available updates. 

If you have updates available, a screen opens listing the 
updates. Select the updates you want and click Download.	

Usage Meter
Click to view data usage
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When downloading large files like software updates and movies, 
use your nearest HotSpot access point or home Internet connection 
to avoid going over your usage allowance.

Connect to other Wi-Fi Networks
The webConnect Manager comes pre-loaded with settings for the 
T-Mobile HotSpot Network, but connecting to other Wi-Fi networks 
is as easy as connecting to T-Mobile HotSpot. 

1.		 Make sure that you are at a location with Wi-Fi access.
2.		 Open the webConnect Manager and click the Wi-Fi tab.
3.		 Click Networks to display a list of available Wi-Fi networks. 
4.		 Click Connect for the desired network.

NOTES:  
 
The webConnect Manager will attempt to automatically connect 
to any pre-defined networks set in your network profile settings or 
display the last network connection that you made.
Before you connect to a Wi-Fi network, you should confirm with 
its operator if you will need any additional settings to connect. For 
example, if you are trying to connect to your work Wi-Fi network, 
you should check with your IT administrator for the correct settings. 

5.	Type your username and password. When you have 
successfully logged in, the T-Mobile HotSpot welcome     
screen opens.

TIPS:
The default password for a corporate customer is the last four digits 
of the tax ID.
 
If you forget your username (phone number), open the webConnect 
Manager and click Tools > Network Info > Broadband in 
Connection Manager. Your username is your 10-digit phone 
number.
 
If you forget your password, you can open a browser while at a 
T-Mobile HotSpot location and click Account Management. Follow 
instructions on the screen to reset your password. When done, 
open the webConnect Manager and click the Wi-Fi tab. Click Tools 
> User Credentials. Enter your username and the new password 
and click OK.
 
If you want to auto-save your username and password, you can 
open the webConnect Manager and click the Wi-Fi tab then click 
Tools > User Credentials. Type your username and password 
and select Store this password for future logins.
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Configure VPN 
You need to configure VPN settings before connecting to VPN. 

1.	Open the webConnect Manager and click the  
T-Mobile Broadband tab.

2.	Click Tools > Settings.
3.	Click the VPN tab.
4.	Click Use existing VPN profile.
5.	Select the VPN client and profile from the drop-down boxes.
6.	Click OK. 

 
You should see the VPN icon appear on the webConnect 
Manager screen. The next time that you connect to 
broadband, the VPN client automatically launches.

Virtual Private Network (VPN)

Virtual Private Networks (VPN) are extensions of private networks 
that you can access over a public network, such as the Internet. 
For example, a large company may implement a VPN so that 
employees can connect to the corporate network from remote 
locations over the Internet. To connect to a VPN, you may need 
special software or settings on your laptop. Please check with your 
IT administrator for software or settings needed to connect to VPN.
The webConnect Manager currently supports VPN clients from the 
following vendors:

n	 Microsoft®

n	 Cisco Systems®

n	 Nortel Networks Limited®

n	 Check Point Software Technologies Ltd.®
n	 NetMotion Wireless
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Connect to VPN manually
If you have configured VPN, you will see the VPN icon on the  
webConnect Manager screen.

1.	At the webConnect Manager screen, click the VPN icon.
2.	Sign in to your VPN account to connect.

VPN
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International use requires international service activation; usage does 
not apply toward webConnect plan limit. International rates apply.

Coverage: Service not available everywhere; HSPA+ and 3G coverage 
available in certain markets.  See brochures, and T-Mobile’s Terms 
and Conditions (including arbitration provision) at www.t-
Mobile.com, for coverage maps, rate plan information, charges 
for features and services, and restrictions and details. T-Mobile and 
the magenta color are registered trademarks of Deutsche Telekom 
AG. webConnect is a 2010 trademark and webConnect Rocket is a 
trademark of T-Mobile USA, Inc.  
©2010 T-Mobile USA, Inc.

Additional Information

Data Plans: You will be charged for all data sent by or to you through 
the network, regardless of whether received. Data speed is variable 
and may be impacted by network conditions and traffic. There is no 
additional charge for HSPA+ usage. Your data session, plan or service 
may be slowed, suspended, terminated or restricted if you use your 
service in a way that interferes with or impacts our network or ability 
to provide quality service to other users, if you roam for a significant 
portion of your usage, or if you use a disproportionate amount of 
bandwidth during a billing cycle. You may not use your plan or device 
for the prohibited uses listed in your data plan terms. T-Mobile is not 
responsible for any third party content or Web site you access using 
your device. T-Mobile cannot guarantee the security of any Internet 
communications. See your data plan terms at www.T-Mobile.com for 
additional details. If you access the T-Mobile HotSpot Network, your 
use is subject to the T-Mobile HotSpot Terms and Conditions, available 
at hotspot.t-mobile.com. 

webConnect: Overage charges apply; partial megabytes rounded 
up for billing. webConnect device required; not voice-capable. Device 
may not be shared in any manner, including use with a network or more 
than one computer or other device. Device requires a specific data 
plan; if you do not have the right plan, you may not be able to use data 
services. Domestic roaming not possible. Roaming charges may apply 
to use via non T-Mobile owned Wi-Fi networks. 
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